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Chapter1. Overview and Board Description 
 
_________________________________________________________________________________ 

 

Introduction 
 
        I2C LCD Blue Board for arduino based on microchip MCP23008 provides 
8bit I/O port expander with serial interface which can interface to several devices up 
to 8 devices on one bus. Each device must have a different address, three address 
pins, high-speed I2C interface 3400KHZ, and including LCD 16characters x 2lines 
with LCD-STN negative blue type is white character on blue background. LCD text & 
numeric display interface to I2C bus are SCL and SDA and support LCD contrast 
adjustment with fine adjustment of a trimpot to any desired contrast setting and 
support LED backlight-white to turn on or turn off the LED backlight with program 
control LED backlight to save power and including pull-up resistors to "pull-up" the 
signals to prevent SCL line & SDA line from floating. Pull-up resistors set default 
value when there is no signal at the input and including I2C bus cable to connect 
other boards on I2C bus and including JP6 Jumper to write data to LCD or read data 
from LCD. 
User can learn I2C LCD Blue Board with example programs as follows : 
        - Autoscroll_I2C program 
        - Blink_I2C program 
        - Cursor_I2C program 
        - Display_I2C program 
        - HelloWorld_I2C program 
        - Scroll_I2C program 
        - SerialDisplay_I2C program 
        - setCursor_I2C program 
        - TextDirection_I2C program 
 

 
 

Figure 1. 
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  Board Feature 

 

 
Figure 2. 

 
1. LCD 16characters x 2lines : LCD-STN negative blue type is white character on 

blue background. LCD text & numeric display interface to I2C bus are SCL and 
SDA. 

2. Including Microchip MCP23008 : 8bit I/O port expander with serial interface 
which can interface to several devices up to 8 devices on one bus. Each device 
must have a different address, three address pins, high-speed I2C interface 
3400KHZ, voltage supply 1.8V to 5.5V, current 1mA. 

3. Support LCD Contrast Adjustment with fine adjustment of a trimpot to any 
desired contrast setting. 

4. Support LED Backlight-White to turn on or turn off LED backlight with program 
control LED backlight to save power. 

5. Including Pull-up Resistors to "pull-up" the signals to prevent SCL line & SDA 
line from floating. Pull-up resistors set default value (5Vdc) when there is no 
signal at the input. 

6. Including Libraries and Examples for learning quickly. 
7. Including a I2C Bus Connector to connect other boards on I2C bus are SCL line 

and SDA line. I2C bus connector consists of +5V, SCL, SDA and GND pin. 
8. Including I2C Bus Cable to connect other boards on I2C bus. 
9. Including JP6 Jumper to write data to LCD or read data from LCD. 
10. Operating voltage of I2C LCD Blue Board is 5Vdc. 
11. Board Dimension is 36.0mm(Width) * 80.0mm(Long) * 23.0mm(High). 
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  Board Description 

 

 
Figure 3. 

 
No1. is a Trimpot Variable Resistor 10KΩ ± 10%, 0.5w to fine adjust LCD contrast 

to any desired contrast setting. 
No2. is JP4 Jumper & JP5 Jumper (Default) connect to pull up resistors for enable 

pull up resistors to "pull-up" the signals to prevent SCL line & SDA line and set 
default value (5Vdc) when there is no signal at the input. 
* If your another board have I2C bus system is pull up resistors that 
recommend you should be de-solder JP4 jumper and JP5 jumper to disable 
pull up resistors of I2C LCD Blue Board. 
* SCL is a serial clock line and SDA is a serial data line. 

No3. is microchip MCP23008 provides 8bit I/O port expander with serial interface 
which can interface to several devices up to 8 devices on one bus. Each 
device must have a different address, three address pins, parallel I/O 
expansion for I2C bus or SPI applications, high-speed I2C interface 3400Khz, 
voltage supply 1.8V to 5.5V, current 1mA. 
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No4. is A2, A1, A0 Jumpers will be set device address to interface your device.  
This I2C LCD Blue Board sets address = 0 (Default).  
A2, A1, A0 jumpers are disable. 
* If you must have interface to several devices up to 8 devices on one bus. 
Each device must have a different address and must solder A2, A1, A0 
jumbers (Optional address = 0 to 7).  
A2, A1, A0 jumpers are enable.  

No5. is a I2C Bus Connector to connect other boards on I2C bus are SCL line and 
SDA line. I2C bus connector consists of +5V, SCL, SDA and GND pin. 

No6. Is JP6 Jumper will be set RW pin to write data to LCD or read data from LCD 
This I2C LCD Blue Board sets default to write data to LCD by solder JP6 
jumper to connect GND. RW pin is cleared (0). 
* Optional is set RW pin to read data from LCD by de-solder JP6 jumper to 
disconnect GND. RW pin is (1). 

No7. is Pin Header 16pins connect between I2C and LCD. 
No8. is LCD 16characters x 2lines, LCD-STN negative blue type is white character 

on blue background, transmissive rear polarizer, 16x2 display format, 5x8 
character format, 2.95x5.55mm. character size, LED backlight-white backlight, 
62.2x17.9mm. viewing area, -20°C to +70°C operating temperature, 5Vdc 
voltage supply, 0.55x0.65mm. dot size, parallel Interface, white dot/blue 
background power on appearance. LCD text & numeric display interface to 
I2C bus are SCL and SDA. 
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  Schematic 
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_________________________________________________________________________________ 

 

Chapter2. Getting Started 
 
_________________________________________________________________________________ 

 

Safety Instruction 

 
   Observe the following safety guideline when connection and using I2C LCD 
Blue Board as following : 

• Place I2C LCD Blue Board on insulation surface and treat it carefully.  
It can be damaged if dropped. 

• Put I2C LCD Blue Board in a location with low humidity and a minimum of 
dust. 

• Never use I2C LCD Blue Board has been damaged. Do not allow anything to 
rest on it and keep it away from where people could trip over it. 

• Never insert anything metallic into I2C LCD Blue Board. Doing so may create 
the danger of electric shock. 

• To avoid electric shock, never touch the inside of the I2C LCD Blue Board. 

• I2C LCD Blue Board is provided for ventilation. To prevent overheating, these 
openings should not be blocked or covered. Also, avoid using I2C LCD Blue 
Board on a bed, sofa, rug, or other soft surface. 

• Do not expose I2C LCD Blue Board to rain or use it near water. 
If It accidentally gets wet, unplug it and you can clean the exterior of the I2C 
LCD Blue Board with a dry cloth when necessary, but be sure to unplug I2C 
LCD Blue Board first.  
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Install Arduino Software 
 
        Software to development is contained in a free CD. If user want to more 
informations or latest version of program that you can be downloaded on website 
www.mlt-group.com to download manual latest version and etc. 
 

 Update New Version : 
 - Revise Arduino Software from “Arduino 1.0.3” to “Arduino 1.0.5-r2 (Latest version)” 
 
1. Insert a free CD into the CD-ROM Drive. 
2. Copy Arduino Software from a free CD is choose folder  

“Arduino Software\Windows\arduino-1.0.3” into drive “C:\Program Files” 
as figure 5.  

  
 

Figure 5. 
 

3. After already copied this folder “arduino-1.0.3” then create shortcut of this 
program “arduino-1.0.3” on your desktop is right-click on icon          

“arduino ” then select “Send To>Desktop (create shortcut)” as figure 6.  

  
 

Figure 6. 
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4. After already created the shortcut then it will be shown           

“Shortcut to arduino” on your desktop. 
5. Then copy example programs of the I2C LCD Blue Board from a free CD is 

choose folder “Libraries Examples> LiquidCrystal_I2C” into drive  
“C:\Program Files\ arduino-1.0.3\ libraries” as figure 8. 
 

 
Figure 7.  

 

 
Figure 8.  
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 Starting I2C LCD Blue Board for Arduino 

 
        Example to development is contained in a free CD. If user want to more 
informations or latest version of program that you can be downloaded on website 
www.mlt-group.com to download manual latest version and etc. 
 
1. Connect this I2C LCD Blue Board to your arduino motherboard with I2C bus 

cable as figure 9.  
* If you have our product is “SD Card Shield Plus for arduino” you can connect 
I2C LCD Blue Board to SD Card Shield Plus with I2C bus cable as figure 10. 

 
Figure 9. 

 
Figure 10. 
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2. Double click on icon “Arduino ” program (Or double click “Shortcut to 
arduino” on your desktop) to open “arduino-1.0.3” on your computer which this 
version includes LiquidCrystal_I2C libraries and example programs. 

3. Open an example program is “HelloWorld_I2C program” to will be tested 
this I2C LCD Blue Board is choose  
“File>Examples> LiquidCrystal_I2C > HelloWorld_I2C” as figure 11. 
 

 
Figure 11. 
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4. After opened an example program is “HelloWorld_I2C program” will be shown 
detail of the C language code as figure 12.  

 

 
Figure 12. 

 
5. Choose “Sketch>Verify/Compile” or click icon as figure 13. to verify and compile 

C language code. 
 

 
 

Figure 13. 
 
6. If C language code is correct and not found data error then information will be 

shown “Done compiling” and “Binary sketch size” as figure 14. 
 

 
Figure 14. 

 
7. Choose “File > Upload to I/O Board” or click icon as figure 15. to upload program 

into your arduino motherboard. 
 

 
Figure 15. 
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8. If completely uploaded an example program (ReadWrite program) then 
information will be shown “Done uploading” and “Binary sketch size”  
as figure 16. 
 

 
Figure 16. 

 
9. Upload an example program is “LiquidCrystal_I2C>HelloWorld_I2C” into  

this I2C LCD Blue Board. If completely uploaded an example program is 
HelloWorld_I2C program then LCD Displaying of text & numeric character will be 
shown “hello, world! I2C LCD” as figure 17. 
 

 
Figure 17. 

 
Author : www.mlt-group.com  
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________________________________________________________________________________ 

 

Chapter3. Index 
 
_________________________________________________________________________________ 
 

Arduino Software Versions :  
 

•   Arduino 1.0.5-r2 version (Latest version includes in a Free CD) support 
Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0.5 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0.4 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0.3 version support Windows, Mac OS X, Linux (32 bit, 64 bit) 

• Arduino 1.0.2 version support Windows, Mac OS X, Linux (32 bit, 64 bit) 

• Arduino 1.0.1 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 0023 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 0022 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 0021 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0020 version support Windows, Mac OS X 

• Arduino 0019 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0018 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0017 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0016 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0015 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0014 version support Windows, Mac OS X 

• Arduino 0013 version support Windows, Mac OS X, Linux (32bit) 

• Arduino 0012 version support Windows, Mac OS X, Linux (32bit),  
Linux (AMD 64bit) 

• Arduino 0011 version support Mac OS X, Windows, Linux 

• Arduino 0010 version support Mac OS X, Windows, Linux 

• Arduino 0009 version support Mac OS X (>= 10.3.9):  
PPC (10.4, 10.3.9), Intel. Windows. Linux 

• Arduino 0008 version support Mac OS X (>= 10.3.9) PPC, Intel.  
Windows 

• Arduino 0007 version support Mac OS X (>= 10.3.9): PPC, Intel.    
Windows, Linux 

• Arduino 0006 version support Mac OS X (>= 10.3.9): PPC, Intel.  
Windows 

• Arduino 0005 version support Mac OS X (>= 10.3.9), PPC, Intel.  
Windows  

• Arduino 0004 version support Mac OS X (>= 10.3.9). Windows 
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• Arduino 0003 version support Mac OS X PPC / Mac OS X Intel,  
Windows 

• Arduino 0002 version support Mac OS X, Windows 

• Arduino 0001 version support Mac OS X, Windows (with Java /  
without Java) 

 

Example Programs : 
• Autoscroll_I2C program  

• Blink_I2C program  

• Cursor_I2C program  

• Display_I2C program  

• HelloWorld_I2C program  

• Scroll_I2C program  

• SerialDisplay_I2C program 

• setCursor_I2C program 

• TextDirection_I2C program 
All example programs includes in a Free CD. 
 

References : 
• www.mlt-group.com 

• www.mltelectronic.com 

• www.arduino.cc 
 

Contact Us : 
1. MLT sells products on Ebay. If you will buy our product via Ebay.  

Seller ID is mlt-group  
2. MLT accepts Paypal payment. If you will buy our product via Paypal.  

Paypal account is mlt@windowslive.com  

3. www.mlt-group.com   
Email: sales@mlt-group.com or mlt@windowslive.com       
Tel. 081-027-0918 

 


