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Chapter1. Overview and Board Description 
 
_________________________________________________________________________________ 

 

Introduction 
 
        SD Card Shield Plus for Arduino is well designed Data Logging Shield 
works with arduino board and SD card. The SD Card Shield Plus includes I2C 
EEPROM-24LC256 (32Kbyte) : Electrically Erasable Programmable Read Only 
Memory is a type of non volatile memory used in computers and other electronic 
devices to store small amounts of data that must be saved when power is removed 
and also includes Real Time Clock (RTC-DS1307) timestamps all your data with the 
current time. Datetime format is YYYYMMDDHHMMSS between 1970-01-01 
00:00:00 to 2037-12-31 23:59:59 (Year-Month-Day).  
User can learn SD Card Shield Plus with example programs as follows : 
        - ReadWrite program 
        - Datalogger program 
        - DumpFile program 
        - Files program 
        - CardInfo program 
        - Listfiles program 
User can use SD Card Shield Plus for Arduino to design projects requiring RTC and 
SD card for logging time stamped data, Read Write Data to SD Card and develop 
to be Data Logger. 

 
 

Figure 1. 
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  Board Feature 

 

 
Figure 2. 

 
1. Support FAT16 or FAT32 file system on SD card (interface works with FAT16 or 

FAT32 formatted SD card) to be read by any plotting, analysis program, 
spreadsheet. 

2. Support SD card or SDHC card (Secure Digital High Capacity, SD 2.0) : SDHC 
memory card provides more removable storage power which increases card's 
storage capacity up to 32 GB. 

3. Plus1, including I2C EEPROM-24LC256 (32Kbyte) : Electrically Erasable 
Programmable Read Only Memory is a type of non volatile memory used in 
computers and other electronic devices to store small amounts of data that must 
be saved when power is removed. 

4. Plus2, including Real Time Clock (RTC-DS1307) timestamps all your data 
with the current time. Datetime format is YYYYMMDDHHMMSS between 1970-
01-01 00:00:00 to 2037-12-31 23:59:59 (Year-Month-Day). RTC keeps the time 
going when power is removed. 

5. Including Libraries and Examples for learning quickly. 
6. RTC battery 3V (CR2032) backup lasts for years (this battery type is cheap price 

for maintenance).  
7. Including 3.3v level shifter circuitry prevents damage to your SD card. 
8. Onboard includes 3.3v regulator outputs a steady and stable 3.3V DC output 

direct to SD card.  
9. Including I2C connector 4 pins will be connected with external I2C devices or 

other boards.  
10. Including Stacking Headers with Arduino Standard 0.1" Headers 8pins & 6pins 

will be stacked with other arduino boards. 
11. Board Dimension is 53.3mm(Width) * 68.6mm(Long) * 19.0mm(High). 
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  Board Description 

 

 
 

Figure 3. 
 
No1. is SD Card Slot (Standard) will be connected with SD card. 
No2. is 3.3v regulator outputs a steady and stable 3.3Vdc output direct to SD card. 
No3. is Tact Switch will be reset operation of microcontroller (Arduino board).  
No4. is I2C EEPROM-24LC256 (32Kbyte) : Electrically Erasable Programmable 

Read-Only Memory is a type of non-volatile memory used in computers and 
other electronic devices to store small amounts of data that must be saved 
when power is removed.  

No5. is Real Time Clock (RTC-DS1307) timestamps all your data with the current 
time. Datetime format is YYYYMMDDHHMMSS between 1970-01-01 
00:00:00 to 2037-12-31 23:59:59 (Year-Month-Day) and RTC-battery 3V 
(CR2032) backup lasts for years. 

No6. is I2C Connector 4 pins will be connected with external I2C devices or other 
boards. 

No7. is RTC battery 3V (CR2032) backup lasts for years. 
No8. is 3.3v level shifter circuitry prevents damage to your SD card.  
No9. is LED1-PWR (Green LED) will be lighted when power is supplied into 

the SD Card Shield Plus.  
And LED2-CD (Yellow LED : Card detection) will be lighted when inserted  
SD card. 

No10.is JP3-Jumper (Default) will be selected SD_CS pin is connected with D10 pin 
but if user want to design SD_CS pin will be connected with other pins by  
de-solder JP3-Jumper (SD_CS pin is broken out of D10 pin). 
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No11.is JP1-Jumper (Default) and JP2-Jumper (Default) will be selected SCL pin 
and SDA pin are connected with external I2C devices or other boards. 
a) JP1-Jumper (Default) will be selected SCL pin is connected with A5 pin but  
     if user want to design SCL pin will be connected with other pins by 
    de-solder JP1-Jumper (SCL pin is broken out of A5 pin). 
b) JP2-Jumper (Default) will be selected SDA pin is connected with A4 pin but  
     if user want to design SDA pin will be connected with other pins by  
    de-solder JP2-Jumper (SDA pin is broken out of A4 pin). 

No12.is Stacking Headers with Arduino Standard 0.1" Headers 8 pins & 6 pins will 
be stacked with other arduino boards. 

 

Standard Signal Pins between SD Card Shield Plus and other arduino boards. 
 

 
 

Table 4. Common standard signal pins 
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  Schematic 
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Chapter2. Getting Started 
 
_________________________________________________________________________________ 

 

Safety Instruction 

 
   Observe the following safety guideline when connection and using  
SD Card Shield Plus as following : 

• Place SD Card Shield Plus on insulation surface and treat it carefully.  
It can be damaged if dropped. 

• Put SD Card Shield Plus in a location with low humidity and a minimum of 
dust. 

• Never use SD Card Shield Plus has been damaged. Do not allow anything to 
rest on it and keep it away from where people could trip over it. 

• Never insert anything metallic into SD Card Shield Plus. Doing so may create 
the danger of electric shock. 

• To avoid electric shock, never touch the inside of the SD Card Shield Plus. 

• SD Card Shield Plus is provided for ventilation. To prevent overheating, these 
openings should not be blocked or covered. Also, avoid using SD Card Shield 
Plus on a bed, sofa, rug, or other soft surface. 

• Do not expose SD Card Shield Plus to rain or use it near water. 
If It accidentally gets wet, unplug it and you can clean the exterior of the SD 
Card Shield Plus with a dry cloth when necessary, but be sure to unplug SD 
Card Shield Plus first.  
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Install Arduino Software 
 
        Software to development is contained in a free CD. If user want to more 
informations or latest version of program that you can be downloaded on website 
www.mlt-group.com to download manual latest version and etc. 
 

 Update New Version : 
 - Revise Arduino Software from “Arduino 1.0.3” to “Arduino 1.0.5-r2 (Latest version)” 
 
1. Insert a free CD into the CD-ROM Drive. 
2. Copy Arduino Software from a free CD is choose folder  

“Arduino Software\Windows\arduino-1.0.3” into drive “C:\Program Files” 
as figure 5.  

  
 

Figure 5. 
 

3. After already copied this folder “arduino-1.0.3” then create shortcut of this 
program “arduino-1.0.3” on your desktop is right-click on icon          

“arduino ” then select “Send To>Desktop (create shortcut)” as figure 6.  

  
 

Figure 6. 
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4. After already created the shortcut then it will be shown           

“Shortcut to arduino” on your desktop. 
5. Then copy example programs of the SD Card Shield Plus from a free CD is 

choose folder “Examples_SD_Shield” into drive  
“C:\Program Files\ arduino-1.0.3\examples” as figure 8. 

 
Figure 7. 

 

 
Figure 8. 
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 Starting SD Card Shield Plus for Arduino 

 
        Example to development is contained in a free CD. If user want to more 
informations or latest version of program that you can be downloaded on website 
www.mlt-group.com to download manual latest version and etc. 
 
1. Insert your SD card into SD card reader of your computer to format your SD card 

for FAT16 or FAT32 file system as figure 9.  

  
Figure 9. 

 
2. After already formatted your SD card then take off the formatted SD card from 

SD card reader of your computer. 
3. Stack SD Card Shield Plus to your another arduino board via Stacking Headers 

with Arduino Standard 0.1" Headers 8 pins & 6 pins as figure 10. 

  
Figure 10. 
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4. Insert the formatted SD card into SD card slot of SD Card Shield Plus and 
connects your another arduino board to your computer via USB cable  
as figure 11.  

  
Figure 11. 

 

5. Double click on icon “Arduino ” program 
(Or double click “Shortcut to arduino” on your desktop) to open “arduino-1.0.3” 
on your computer which a free CD includes SD card libraries and  
example programs. 
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6. Open an example program is “ReadWrite program” to will be tested this SD Card 
Shield Plus is choose “File>Examples>Examples_SD_Shield >SD>ReadWrite” 
as figure 12. 
 

 
Figure 12. 

 
7. After opened an example program is “ReadWrite program” will be shown detail 

of the C language code as figure 13. 
 

  
Figure 13. 
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8. Choose “Sketch>Verify/Compile” or click icon as figure 14. to verify and compile 
the C language code. 
 

  
Figure 14. 

 
9. If the C language code is correct and not found data error then information will 

be shown “Done compiling” and “Binary sketch size” as figure 15. 
 

  
Figure 15. 

 
10. Choose “File > Upload to I/O Board” or click icon as figure 16. To upload 

program into your arduino board. 
 

  
Figure 16. 

 
11. If completely uploaded an example program (ReadWrite program) then 

information will be shown “Done uploading” and “Binary sketch size”  
as figure 17. 
 

 
Figure 17. 

 
12. Click icon is “Serial Monitor” as figure 18. to will be shown data about receives 

and sends data via the serial port. 
 

  
Figure 18. 
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13. After clicked icon is “Serial Monitor” then will be shown “window of serial monitor 
” as figure 19. is completely wrote “test.txt file” into SD card. 
 

  
Figure 19 

 
14. You take off SD card from the SD card slot of SD Card Shield Plus. 
15. Insert SD card into the SD card reader of your computer then open data in SD 

card will be found “test.txt file” then double click “test.txt file” will be shown 
data is wrote into SD card as figure 20. 
 

 
 

Figure 20. 
 
Author : www.mlt-group.com  
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Chapter3. Index 
 
_________________________________________________________________________________ 
 

Arduino Software Versions :  
 

•   Arduino 1.0.5-r2 version (Latest version includes in a Free CD) support 
Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0.5 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0.4 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0.3 version support Windows, Mac OS X, Linux (32 bit, 64 bit) 

• Arduino 1.0.2 version support Windows, Mac OS X, Linux (32 bit, 64 bit) 

• Arduino 1.0.1 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 1.0 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 0023 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 0022 version support Windows, Mac OS X, Linux (32 bit/64 bit) 

• Arduino 0021 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0020 version support Windows, Mac OS X 

• Arduino 0019 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0018 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0017 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0016 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0015 version support Windows, Mac OS X, Linux (32 bit) 

• Arduino 0014 version support Windows, Mac OS X 

• Arduino 0013 version support Windows, Mac OS X, Linux (32bit) 

• Arduino 0012 version support Windows, Mac OS X, Linux (32bit),  
Linux (AMD 64bit) 

• Arduino 0011 version support Mac OS X, Windows, Linux 

• Arduino 0010 version support Mac OS X, Windows, Linux 

• Arduino 0009 version support Mac OS X (>= 10.3.9):  
PPC (10.4, 10.3.9), Intel. Windows. Linux 

• Arduino 0008 version support Mac OS X (>= 10.3.9) PPC, Intel.  
Windows 

• Arduino 0007 version support Mac OS X (>= 10.3.9): PPC, Intel.    
Windows, Linux 

• Arduino 0006 version support Mac OS X (>= 10.3.9): PPC, Intel.  
Windows 

• Arduino 0005 version support Mac OS X (>= 10.3.9), PPC, Intel.  
Windows  

• Arduino 0004 version support Mac OS X (>= 10.3.9). Windows 
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• Arduino 0003 version support Mac OS X PPC / Mac OS X Intel,  
Windows 

• Arduino 0002 version support Mac OS X, Windows 

• Arduino 0001 version support Mac OS X, Windows (with Java /  
without Java) 

 

Example Programs : 
• ReadWrite program 

• Datalogger program 

• DumpFile program 

• Files program 

• CardInfo program 

• listfiles program 
All example programs includes in a Free CD. 
 

References : 
• www.mlt-group.com 

• www.mltelectronic.com 

• www.arduino.cc 
 

Contact Us : 
1. MLT sells products on Ebay. If you will buy our product via Ebay.  

Seller ID is mlt-group  
2. MLT accepts Paypal payment. If you will buy our product via Paypal.  

Paypal account is mlt@windowslive.com  

3. www.mlt-group.com   
Email: sales@mlt-group.com or mlt@windowslive.com       
Tel. 081-027-0918 

 


